package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(?:#.*|)$`)
var str = `Multiline input text
Mid-sentence# cut, this won't be matched
Hey there`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}