re = /^(.*?)(?:#.*|)$/m
str = 'Multiline input text
Mid-sentence# cut, this won\'t be matched
Hey there'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end