package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\x{0600}-\x{06FF}\s]+$`)
var str = `عمر انی`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}