import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<_time>[^,]+),\\s+queue_name:\\s*(?<queue_name>[^,]+),\\s+messages:\\s*(?<messages>.+),.*bytes:\\s*(?<bytes>[^,]+),\\s*actCusumers:\\s*(?<actCusumers>[^,]+),\\s*numSubjects:\\s*(?<numSubjects>\\d+)";
final String string = "2023-03-21 04:14:13.859, queue_name:stream-AccountProfile, messages: 16, bytes: 13 KiB, actCusumers: 4, numSubjects: 1\n"
+ "2023-03-21 04:14:13.859, queue_name:stream-SampleProfile, messages: 3,522, bytes: 2.4 MiB, actCusumers: 4, numSubjects: 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}