const regex = /^(?<_time>[^,]+),\s+queue_name:\s*(?<queue_name>[^,]+),\s+messages:\s*(?<messages>.+),.*bytes:\s*(?<bytes>[^,]+),\s*actCusumers:\s*(?<actCusumers>[^,]+),\s*numSubjects:\s*(?<numSubjects>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<_time>[^,]+),\\s+queue_name:\\s*(?<queue_name>[^,]+),\\s+messages:\\s*(?<messages>.+),.*bytes:\\s*(?<bytes>[^,]+),\\s*actCusumers:\\s*(?<actCusumers>[^,]+),\\s*numSubjects:\\s*(?<numSubjects>\\d+)', 'gm')
const str = `2023-03-21 04:14:13.859, queue_name:stream-AccountProfile, messages: 16, bytes: 13 KiB, actCusumers: 4, numSubjects: 1
2023-03-21 04:14:13.859, queue_name:stream-SampleProfile, messages: 3,522, bytes: 2.4 MiB, actCusumers: 4, numSubjects: 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}