$re = '/[\w+]+(?=\.$)/m';
$str = 'My favorite programming language is c++.
My favorite programming language is c.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);