re = /[\w+]+(?=\.$)/m
str = 'My favorite programming language is c++.
My favorite programming language is c.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end