import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^)(\\d{1,2}\\s?x\\s?)?\\d{1,2}((,|\\.)\\d{1,2})?\\s?L?";
final String string = "25 Test Drink 60% 12x1,0L\n"
+ "Test Drink 60% 2x0,5\n"
+ "Test Drink 3 x 0,75 L \n"
+ "Test Drink 4x0,75 L\n"
+ "Test Drink 5 x 0,75L\n"
+ "Test Drink 66 x 0,75 \n"
+ "Test Drink 0,75 \n"
+ "Test Drink 0.75 \n"
+ "7UP 12 x 1 L";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}