import re
regex = re.compile(r"(?<!^)(\d{1,2}\s?x\s?)?\d{1,2}((,|\.)\d{1,2})?\s?L?", flags=re.IGNORECASE)
test_str = ("25 Test Drink 60% 12x1,0L\n"
"Test Drink 60% 2x0,5\n"
"Test Drink 3 x 0,75 L \n"
"Test Drink 4x0,75 L\n"
"Test Drink 5 x 0,75L\n"
"Test Drink 66 x 0,75 \n"
"Test Drink 0,75 \n"
"Test Drink 0.75 \n"
"7UP 12 x 1 L")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")