$re = '/\b(?!(?:https?|ftps?):\/\/)(?!www\.)(?:[0-9A-Za-z][0-9A-Za-z-]{0,62})(?:\.(?:[0-9A-Za-z][0-9A-Za-z-]{0,62}))*(?:\.?|\b)/';
$str = 'www.stackoverflow.com
http://www.stackoverflow.com
https://www.stackoverflow.com
ftps://www.stackoverflow.com
ftp://www.stackoverflow.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);