re = /\b(?!(?:https?|ftps?):\/\/)(?!www\.)(?:[0-9A-Za-z][0-9A-Za-z-]{0,62})(?:\.(?:[0-9A-Za-z][0-9A-Za-z-]{0,62}))*(?:\.?|\b)/
str = 'www.stackoverflow.com
http://www.stackoverflow.com
https://www.stackoverflow.com
ftps://www.stackoverflow.com
ftp://www.stackoverflow.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end