#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)((\b\d+)(?:\sPI?N ?#? ?))|((?:PI?N ?#? ?)(\d+))"
Local $sString = "9999XX00999X PIN # 999999" & @CRLF & _
"9999XX000999 - PIN#909999" & @CRLF & _
"XXXXX XX PIN #9099999" & @CRLF & _
"9999XX99X PIN999099" & @CRLF & _
"99XX999X PN 9999999" & @CRLF & _
"9999999 PIN" & @CRLF & _
"90PA999 PN 999999" & @CRLF & _
"999009 PIN#" & @CRLF & _
"99PA99 PN#9999999" & @CRLF & _
"PIN 999990" & @CRLF & _
"XXXPIN990999" & @CRLF & _
"PIN#999099" & @CRLF & _
"PIN# 9990909" & @CRLF & _
"PIN#9099999*"
Local $sSubst = "test\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)