import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\b\\d+)(?:\\sPI?N ?#? ?))|((?:PI?N ?#? ?)(\\d+))";
final String string = "9999XX00999X PIN # 999999\n"
+ "9999XX000999 - PIN#909999\n"
+ "XXXXX XX PIN #9099999\n"
+ "9999XX99X PIN999099\n"
+ "99XX999X PN 9999999\n"
+ "9999999 PIN\n"
+ "90PA999 PN 999999\n"
+ "999009 PIN#\n"
+ "99PA99 PN#9999999\n"
+ "PIN 999990\n"
+ "XXXPIN990999\n"
+ "PIN#999099\n"
+ "PIN# 9990909\n"
+ "PIN#9099999*";
final String subst = "test\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}