$re = '/\s*(\w+)\s*:\s*(\w+)\s*/m';
$str = 'option1:value1 option2: value2 option3 :value3 option4 : value4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);