re = /\s*(\w+)\s*:\s*(\w+)\s*/m
str = 'option1:value1 option2: value2 option3 :value3 option4 : value4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end