#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(post|put|delete|get)( (?!\1)(?1))*$"
Local $sString = "post" & @CRLF & _
"post put" & @CRLF & _
"get put post" & @CRLF & _
"post post" & @CRLF & _
"[space]post" & @CRLF & _
"get[space]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")