re = /^(post|put|delete|get)( (?!\1)(?1))*$/m
str = 'post
post put
get put post
post post
[space]post
get[space]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end