const regex = /^((post|put|delete|get)(?!.*\2))( (?1))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((post|put|delete|get)(?!.*\\2))( (?1))*$', 'gm')
const str = `post
post put
get put post
get post post
[space]post
get[space]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}