$re = '/^((post|put|delete|get)(?!.*\2))( (?1))*$/m';
$str = 'post
post put
get put post
get post post
[space]post
get[space]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);