#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!€*$)(€ ?(?!.*€)(?=,?\d))?\-?([1-9]{1,3}( \d{3})*|[1-9]{1,3}(\.\d{3})*|(0|([1-9]\d*)?))(,[0-9]{2})?( ?€)?$"
Local $sString = "valid:" & @CRLF & _
"" & @CRLF & _
"123 456,78" & @CRLF & _
"123.456,78" & @CRLF & _
"€6.954.231" & @CRLF & _
"€ 896.954.231" & @CRLF & _
"16.954.231 €" & @CRLF & _
"12 346 954 231€" & @CRLF & _
"€10,03" & @CRLF & _
"10,03" & @CRLF & _
"1,39" & @CRLF & _
",03" & @CRLF & _
"0,10" & @CRLF & _
"€10567,01" & @CRLF & _
"€ 0,01" & @CRLF & _
"€1 234 567,89" & @CRLF & _
"€1.234.567,89" & @CRLF & _
"€,10" & @CRLF & _
"€ ,10" & @CRLF & _
"" & @CRLF & _
"invalid" & @CRLF & _
"" & @CRLF & _
"1,234 € 1,1" & @CRLF & _
"50#,50" & @CRLF & _
"123,@€" & @CRLF & _
"€€500" & @CRLF & _
"0001" & @CRLF & _
"€ ,001" & @CRLF & _
"€0,001" & @CRLF & _
"12.34,56" & @CRLF & _
"123456.123.123456" & @CRLF & _
"€123€" & @CRLF & _
"" & @CRLF & _
"€"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")