import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!€*$)(€ ?(?!.*€)(?=,?\\d))?\\-?([1-9]{1,3}( \\d{3})*|[1-9]{1,3}(\\.\\d{3})*|(0|([1-9]\\d*)?))(,[0-9]{2})?( ?€)?$";
final String string = "valid:\n\n"
+ "123 456,78\n"
+ "123.456,78\n"
+ "€6.954.231\n"
+ "€ 896.954.231\n"
+ "16.954.231 €\n"
+ "12 346 954 231€\n"
+ "€10,03\n"
+ "10,03\n"
+ "1,39\n"
+ ",03\n"
+ "0,10\n"
+ "€10567,01\n"
+ "€ 0,01\n"
+ "€1 234 567,89\n"
+ "€1.234.567,89\n"
+ "€,10\n"
+ "€ ,10\n\n"
+ "invalid\n\n"
+ "1,234 € 1,1\n"
+ "50#,50\n"
+ "123,@€\n"
+ "€€500\n"
+ "0001\n"
+ "€ ,001\n"
+ "€0,001\n"
+ "12.34,56\n"
+ "123456.123.123456\n"
+ "€123€\n\n"
+ "€";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}