#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(?:(TABLE\d+)|\G)(?:(?!TABLE).)+?(\d+)\s+\|\s+(\d+)"
Local $sString = "TABLE1" & @CRLF & _
"=======" & @CRLF & _
"1 | 2" & @CRLF & _
"15 | 2" & @CRLF & _
"3 | 15" & @CRLF & _
"" & @CRLF & _
"TABLE2" & @CRLF & _
"=======" & @CRLF & _
"3 | 5" & @CRLF & _
"12 | 2" & @CRLF & _
"17 | 7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")