const regex = /(?s)(?:(TABLE\d+)|\G)(?:(?!TABLE).)+?(\d+)\s+\|\s+(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:(TABLE\\d+)|\\G)(?:(?!TABLE).)+?(\\d+)\\s+\\|\\s+(\\d+)', 'gm')
const str = `TABLE1
=======
1 | 2
15 | 2
3 | 15
TABLE2
=======
3 | 5
12 | 2
17 | 7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}