package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\s|[^#\w])+[^#\s]+`)
var str = `Looking for a simple #homemade gift for the #holidays? This #DairyFree #DarkChocolate #Fudge recipe is simple and absolutely delicious: http://sddf.us/fudge`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}