$re = '/(^|\s|[^#\w])+[^#\s]+/m';
$str = 'Looking for a simple #homemade gift for the #holidays? This #DairyFree #DarkChocolate #Fudge recipe is simple and absolutely delicious: http://sddf.us/fudge';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);