package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9|A-Z]{8}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{12}`)
var str = `1F2EB4CE-5A7E-419F-9346-25885EB9D575`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}