import Foundation
let pattern = #"[0-9|A-Z]{8}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{4}-[0-9|A-Z]{12}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1F2EB4CE-5A7E-419F-9346-25885EB9D575"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)