package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[1-4]{0,5}`)
var str = `1112
123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}