$re = '/[1-4]{0,5}/im';
$str = '1112
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);