package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d*(,\d+)?$`)
var str = `0,0
1,2
-12
-23,3
23
34
,23
-,23
23,3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}