$re = '/^\d*(,\d+)?$/m';
$str = '0,0
1,2
-12
-23,3
23
34
,23
-,23
23,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);