const regex = /^(?=.*(?>ABC|DEF))(?=.*(?>COMPUTER|CONSULTING)).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(?>ABC|DEF))(?=.*(?>COMPUTER|CONSULTING)).+', 'gm')
const str = `anyNumberOrNoCharacters ABC anyNumberOrNoCharacters COMPUTER anyNumberOrNoCharacters
anyNumberOrNoCharacters COMPUTER anyNumberOrNoCharacters ABC anyNumberOrNoCharacters
anyNumberOrNoCharacters DEF anyNumberOrNoCharacters CONSULTING anyNumberOrNoCharacters
anyNumberOrNoCharacters CONSULTING anyNumberOrNoCharacters DEF anyNumberOrNoCharacters
ABC CONSULTING
this is an ABC TO CONSULTING asdf or ABCCONSULTING`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}