re = /^(?=.*(?>ABC|DEF))(?=.*(?>COMPUTER|CONSULTING)).+/m
str = 'anyNumberOrNoCharacters ABC anyNumberOrNoCharacters COMPUTER anyNumberOrNoCharacters
anyNumberOrNoCharacters COMPUTER anyNumberOrNoCharacters ABC anyNumberOrNoCharacters
anyNumberOrNoCharacters DEF anyNumberOrNoCharacters CONSULTING anyNumberOrNoCharacters
anyNumberOrNoCharacters CONSULTING anyNumberOrNoCharacters DEF anyNumberOrNoCharacters
ABC CONSULTING
this is an ABC TO CONSULTING asdf or ABCCONSULTING'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end