// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*[)]\B").unwrap();
let string = "x=main2.addMenu('Edit')
x=main2.addMenu('Edit2')
x=main2.addMenu('Edit3')
x=main2.addMenu('Edit4')";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}