using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[)](\r?\n|$)";
string input = @"x=main2.addMenu('Edit')
x=main2.addMenu('Edit2')
x=main2.addMenu('Edit3')
x=main2.addMenu('Edit4')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}