import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*@(\\S+)";
final String string = "From: <email@example.com> FROM name fails\n\n"
+ "Closed (fixed)\n"
+ "Project: \n"
+ "SMTP Authentication Support\n"
+ "Version: \n"
+ "6.x-1.0-beta5\n"
+ "Component: \n"
+ "Code\n"
+ "Priority: \n"
+ "Normal\n"
+ "Category: \n"
+ "Bug report\n"
+ "Assigned: \n"
+ "José San Martin\n"
+ "Reporter: \n"
+ "goose2000\n"
+ "Created: \n"
+ "July 8, 2008 - 12:54\n"
+ "Updated: \n"
+ "October 5, 2012 - 19:01\n"
+ "Log in or register to update this issue\n"
+ "Jump to:\n"
+ "Most recent attachment\n"
+ "Hi, my development site is running on IIS with SMTP server. Mail is working fine when creating new users or getting a password reset. I have built a webform and upon submitting I'll get this error:\n\n\n"
+ " * warning: mail() [function.mail]: SMTP server response: 501 5.5.4 Invalid Address in C:\\Inetpub\\wwwroot\\BHI_dev\\includes\\mail.inc on line 193.\n"
+ " * Unable to send e-mail. Please contact the site admin, if the problem persists.\n\n"
+ "The address I use in my testing are in fact completely valid. Seems like webform is not playing nice with the core somehow. Further ideas?\n\n"
+ "Using Drupal 6.2.\n\n"
+ "Thanks.\n\n"
+ "Files: \n"
+ "Comment File Size Author\n"
+ "#25 smtp_279836.patch 694 bytes scttnlsn\n"
+ "#13 smtp_module_name_patch_279836_01.patch 724 bytes franz\n"
+ "#6 smtp_module_name_patch_279836_01.patch 724 bytes rfay\n"
+ "Comments\n"
+ " goose2000’s picture\n"
+ "Comment #1goose2000 CreditAttribution: goose2000 commented 8 years ago\n"
+ "Priority: Critical » Minor\n"
+ "This seems to be an IIS SMTP issue only. See here:\n\n"
+ "http://drupal.org/node/33967\n\n"
+ "Easy work around is to have no 'name' text , just the email address when you configure webform.\n"
+ "Think it may still be fixable at the code? I set it to 'minor' now.\n\n"
+ "Working great, one of the best modules around.\n"
+ "Log in or register to post comments\n"
+ " quicksketch’s picture\n"
+ "Comment #2quicksketch CreditAttribution: quicksketch commented 7 years ago\n"
+ "Title: Email Invalid Address » \"Name\" <email@example.com> FROM name fails\n"
+ "Project: Webform » SMTP Authentication Support\n"
+ "Version: 6.x-2.1.1 » 6.x-1.0-beta3\n"
+ "Moving to the SMTP module.\n\n"
+ "To summarize, Webform users have not been able to send e-mails when using the SMTP module and the FROM e-mail addresses are formatted as \"First Last\" <email@example.com>. The name is properly mime_header_encoded when necessary.\n\n"
+ "Any users experiencing this issue, please update with the version of SMTP module you're using.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}