import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=, )[0-9]+(\\.[0-9]+)?(?= fps)";
final String string = "8:9 DAR4:3], 23.98 fps\n"
+ "8:9 DAR4:3], 29.97 fps\n"
+ "8:9 DAR4:3], 25 fps\n"
+ "unrelated, 10 string\n"
+ "another, 28 fps string";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}