const regex = /(?<=, )[0-9]+(\.[0-9]+)?(?= fps)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=, )[0-9]+(\\.[0-9]+)?(?= fps)', 'g')
const str = `8:9 DAR4:3], 23.98 fps
8:9 DAR4:3], 29.97 fps
8:9 DAR4:3], 25 fps
unrelated, 10 string
another, 28 fps string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}