import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([a-z]+)[^<>]*>(\\d+(?:[\\.,]\\d+))<\\/\\1>";
final String string = "<strong>230.00</strong></a></td><td class=\"yfnc_tabledata1\"><a href=\"http://ca.finance.yahoo.com/q?s=AMZN121026C00230000\">AMZN121026C00230000</a></td><td class=\"yfnc_tabledata1\" align=\"right\"><b>9.35</b></td><td class=\"yfnc_tabledata1\" align=\"right\"><span id=\"yfs_c10_amzn121026c00230000\"><img style=\"margin-right:-2px;\" src=\"op_files/up_g.gif\" alt=\"Up\" border=\"0\" height=\"14\" width=\"10\"> <span class=\"yfi-price-change-green\">0.35</span></span></td><td class=\"yfnc_tabledata1\" align=\"right\">9.25</td><td class=\"yfnc_tabledata1\" align=\"right\">9.40</td><td class=\"yfnc_tabledata1\" align=\"right\">3,857</td><td class=\"yfnc_tabledata1\" align=\"right\">1,041</td></tr><tr><td class=\"yfnc_tabledata1\" nowrap=\"nowrap\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}