# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<([a-z]+)[^<>]*>(\d+(?:[\.,]\d+))<\/\1>"
test_str = "<strong>230.00</strong></a></td><td class=\"yfnc_tabledata1\"><a href=\"http://ca.finance.yahoo.com/q?s=AMZN121026C00230000\">AMZN121026C00230000</a></td><td class=\"yfnc_tabledata1\" align=\"right\"><b>9.35</b></td><td class=\"yfnc_tabledata1\" align=\"right\"><span id=\"yfs_c10_amzn121026c00230000\"><img style=\"margin-right:-2px;\" src=\"op_files/up_g.gif\" alt=\"Up\" border=\"0\" height=\"14\" width=\"10\"> <span class=\"yfi-price-change-green\">0.35</span></span></td><td class=\"yfnc_tabledata1\" align=\"right\">9.25</td><td class=\"yfnc_tabledata1\" align=\"right\">9.40</td><td class=\"yfnc_tabledata1\" align=\"right\">3,857</td><td class=\"yfnc_tabledata1\" align=\"right\">1,041</td></tr><tr><td class=\"yfnc_tabledata1\" nowrap=\"nowrap\">"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.