using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(121)(?!\d)";
string input = @"1, 121
121
1121
1210
3, 4, 121, 7, 8
3,4,121,7,8
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}