$re = '/(?<!\d)(121)(?!\d)/';
$str = '1, 121
121
1121
1210
3, 4, 121, 7, 8
3,4,121,7,8
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);