package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`pattern = (?<Number>\d+)`)
var str = `[DEBUG]
pattern = 3432`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}