$re = '/pattern = (?<Number>\d+)/';
$str = '[DEBUG]
pattern = 3432';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);