const regex = /^((\d{2}|\d{4})[\/|\.|-](\d{2})[\/|\.|-](\d{4}|\d{2}) (\d{2}):(\d{2}):(\d{2}))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\d{2}|\\d{4})[\\\/|\\.|-](\\d{2})[\\\/|\\.|-](\\d{4}|\\d{2}) (\\d{2}):(\\d{2}):(\\d{2}))$', '')
const str = `2015/12/14 12:12:12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}