re = /^((\d{2}|\d{4})[\/|\.|-](\d{2})[\/|\.|-](\d{4}|\d{2}) (\d{2}):(\d{2}):(\d{2}))$/
str = '2015/12/14 12:12:12'
# Print the match result
str.match(re) do |match|
puts match.to_s
end