package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^[more|most])\s?\w*ly`)
var str = `fastly onffly fly incomprehensibly totaly happily
lily sly more happily
most seriously`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}