$re = '/(?:^[more|most])\s?\w*ly/m';
$str = 'fastly onffly fly incomprehensibly totaly happily
lily sly more happily
most seriously';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);