using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)((\d[a-z]*)-\d*)(\3)([a-z])?";
string input = @"1921-1220104081741b
192123212a-1220234104081742ab
1926h-1220104081746h";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}