$re = '/(\d*)((\d[a-z]*)-\d*)(\3)([a-z])?/m';
$str = '1921-1220104081741b
192123212a-1220234104081742ab
1926h-1220104081746h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);